mixal - A MIX emulator and MIXAL interpreter

Distribution: Ubuntu 12.04 LTS (Precise Pangolin)
Repository: Ubuntu Universe amd64
Package name: mixal
Package version: 1.08
Package release: 11
Package architecture: amd64
Package type: deb
Installed size: 100 B
Download size: 23.94 KB
Official Mirror: archive.ubuntu.com
Mixal is an implementation of the imaginary computer called MIX and its assembly language MIXAL, which were invented by Donald E. Knuth in the 1960's for use in his monumental and yet unfinished book series "The Art of Computer Programming". All actual programs and all programming exercises in the series are written in MIXAL. This package contains a modified version of Darius Bacon's Mixal implementation. It takes a MIXAL source file, translates it to MIX machine code and then executes the resulting program, all in a single run. The result of the assembler step cannot be extracted to a file. Similarly, one cannot take a precompiled MIX program and try to execute it in this emulator - only MIXAL source is accepted. The MIX emulator does not support floating-point operations nor the tape devices described in Knuth's book. This is not fatal, however, and most of the programs and exercise answers in Knuth's book can be run in this MIXAL implementation.




    Binary package: mixal_1.08-11_amd64.deb
    Source package: mixal

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install mixal deb package:
      # sudo apt-get install mixal


    • /usr/bin/mixal
    • /usr/share/doc/mixal/NOTES.gz
    • /usr/share/doc/mixal/READ.ME
    • /usr/share/doc/mixal/README.Debian
    • /usr/share/doc/mixal/changelog.Debian.gz
    • /usr/share/doc/mixal/copyright
    • /usr/share/man/man1/mixal.1.gz


    2011-03-17 - Vince Mulhollon <vlm@debian.org> mixal (1.08-11) unstable; urgency=low * Added ${misc:Depends} to control This fixes lintian debhelper-but-no-misc-depends * Upgraded dh compat from 4 to 8. Updated control and added compat file. This fixes lintian package-uses-deprecated-debhelper-compat-version This also cleans up package-lacks-versioned-build-depends-on-debhelper * Removed DH_COMPAT from rules file. This fixes lintian debian-rules-sets-DH_COMPAT * Removed - from $(MAKE) clean line in rules This fixes lintian debian-rules-ignores-make-clean-error * Bump standards version from to * Removed SC macro in manpage This fixes manpage-has-errors-from-man * Changed from dh_clean -k to dh_prep This fixes lintian dh-clean-k-is-deprecated

    2005-09-16 - Vince Mulhollon <vlm@debian.org> mixal (1.08-10) unstable; urgency=low * Update standards version from to * Debhelper compatibiltiy level from 3 to 4

    2003-05-18 - Vince Mulhollon <vlm@debian.org> mixal (1.08-9) unstable; urgency=low * Manpage now refers to /usr/share/doc (closes: Bug#182064)

    2002-12-04 - Vince Mulhollon <vlm@debian.org> mixal (1.08-8) unstable; urgency=low * Fixed W: mixal: postinst-should-not-set-usr-doc-link * New upstream home page is http://www.accesscom.com/~darius/ * New upstream email is darius@accesscom.com * Policy compliant up to

    2001-12-19 - Vince Mulhollon <vlm@debian.org> mixal (1.08-7) unstable; urgency=low * Fix a typo, Similarlly to Similarly (closes: Bug#125138) * Policy compliance from to

    2001-05-23 - Vince Mulhollon <vlm@debian.org> mixal (1.08-6) unstable; urgency=low * New maintainer. (closes: Bug#68183) * debhelper-ized the package * disabled -g gcc flag to remove debugging code * Policy compliant up to

    1999-10-08 - Antti-Juhani Kaijanaho <ajk@debian.org> mixal (1.08-5) unstable; urgency=low * debian/{rules,prerm,postinst}: Implement the /usr/doc transition.

    1999-07-01 - Antti-Juhani Kaijanaho <ajk@debian.org> mixal (1.08-4) unstable; urgency=low * Upgraded Standards-Version to with necessary changes to debian/rules

    1999-05-27 - Antti-Juhani Kaijanaho <ajk@debian.org> mixal (1.08-3) unstable; urgency=low * GNU libc 2.1 fixes.

    1999-02-04 - Antti-Juhani Kaijanaho <ajk@debian.org> mixal (1.08-2) unstable; urgency=low * Corrected extended description: the disk and console devices are implemented in this version.