mago_0.3+bzr20-0ubuntu3_all.deb


Advertisement

Description

mago - Library and harness for desktop testing

Property Value
Distribution Ubuntu 12.04 LTS (Precise Pangolin)
Repository Ubuntu Universe amd64
Package name mago
Package version 0.3+bzr20
Package release 0ubuntu3
Package architecture all
Package type deb
Installed size 202 B
Download size 32.54 KB
Official Mirror archive.ubuntu.com
It allows the user to write desktop tests for the Linux Desktop without
needing to know how LDTP framework works internally.
ยท
It runs the tests by application and it collects results into XML and HTML
reports.

Alternatives

Package Version Architecture Repository
mago_0.3+bzr20-0ubuntu3_all.deb 0.3+bzr20 all Ubuntu Universe
mago - - -

Requires

Name Value
ldtp -
python >= 2.7.1-0ubuntu2
python << 2.8
python-ldtp -
python-nose -
python-testtools -
python-xlib -
python2.7 -

Download

Type URL
Binary Package mago_0.3+bzr20-0ubuntu3_all.deb
Source Package mago

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mago deb package:
    # sudo apt-get install mago

Files

Path
/usr/bin/mago
/usr/bin/magomatic
/usr/lib/python2.7/dist-packages/mago-0.4.egg-info
/usr/lib/python2.7/dist-packages/mago/__init__.py
/usr/lib/python2.7/dist-packages/mago/application.py
/usr/lib/python2.7/dist-packages/mago/case.py
/usr/lib/python2.7/dist-packages/mago/config.py
/usr/lib/python2.7/dist-packages/mago/core.py
/usr/lib/python2.7/dist-packages/mago/magomatic.py
/usr/lib/python2.7/dist-packages/mago/magomaticconfig.py
/usr/lib/python2.7/dist-packages/mago/struct.py
/usr/lib/python2.7/dist-packages/mago/utils.py
/usr/lib/python2.7/dist-packages/mago/mouse/__init__.py
/usr/lib/python2.7/dist-packages/mago/mouse/base.py
/usr/lib/python2.7/dist-packages/mago/mouse/java_.py
/usr/lib/python2.7/dist-packages/mago/mouse/mac.py
/usr/lib/python2.7/dist-packages/mago/mouse/unix.py
/usr/lib/python2.7/dist-packages/mago/mouse/windows.py
/usr/lib/python2.7/dist-packages/mago/noseplugins/__init__.py
/usr/lib/python2.7/dist-packages/mago/noseplugins/magoxml.py
/usr/lib/python2.7/dist-packages/mago/noseplugins/maybe.py
/usr/lib/python2.7/dist-packages/mago/unity/__init__.py
/usr/lib/python2.7/dist-packages/mago/xlib/__init__.py
/usr/lib/python2.7/dist-packages/mago/xlib/xlib.py
/usr/share/doc/mago/changelog.Debian.gz
/usr/share/doc/mago/copyright
/usr/share/pyshared/mago-0.4.egg-info
/usr/share/pyshared/mago/__init__.py
/usr/share/pyshared/mago/application.py
/usr/share/pyshared/mago/case.py
/usr/share/pyshared/mago/config.py
/usr/share/pyshared/mago/core.py
/usr/share/pyshared/mago/magomatic.py
/usr/share/pyshared/mago/magomaticconfig.py
/usr/share/pyshared/mago/struct.py
/usr/share/pyshared/mago/utils.py
/usr/share/pyshared/mago/mouse/__init__.py
/usr/share/pyshared/mago/mouse/base.py
/usr/share/pyshared/mago/mouse/java_.py
/usr/share/pyshared/mago/mouse/mac.py
/usr/share/pyshared/mago/mouse/unix.py
/usr/share/pyshared/mago/mouse/windows.py
/usr/share/pyshared/mago/noseplugins/__init__.py
/usr/share/pyshared/mago/noseplugins/magoxml.py
/usr/share/pyshared/mago/noseplugins/maybe.py
/usr/share/pyshared/mago/unity/__init__.py
/usr/share/pyshared/mago/xlib/__init__.py
/usr/share/pyshared/mago/xlib/xlib.py

Changelog

2011-12-31 - Matthias Klose <doko@ubuntu.com>
mago (0.3+bzr20-0ubuntu3) precise; urgency=low
* Rebuild to drop python2.6 dependencies.
2011-02-11 - Michael Vogt <michael.vogt@ubuntu.com>
mago (0.3+bzr20-0ubuntu2) natty; urgency=low
* debian/control:
- add missing python-testtools dependency
2011-02-08 - Michael Vogt <michael.vogt@ubuntu.com>
mago (0.3+bzr20-0ubuntu1) natty; urgency=low
* debian/rules:
- updated to debhelper 7
- use dh_python2 instead of python-central
* debian/pycompat:
- removed, no longer needed
* debian/control:
- dropped cdbs and python-central dependencies
* bzr snapshot of the current trunk
2010-12-03 - Ara Pulido <ara@ubuntu.com>
mago (0.3-0ubuntu3) natty; urgency=low
* Updated from trunk
+ Added new applications to our tests base
+ Fixes LP: #682845 
2010-10-18 - Ara Pulido <ara@ubuntu.com>
mago (0.3-0ubuntu1) natty; urgency=low
* New upstream release:
+ Added i18n support
+ Tests working on Maverick 
2010-04-14 - Ara Pulido <ara@ubuntu.com>
mago (0.2-0ubuntu1) lucid; urgency=low
* Mago tests updated for Lucid
+ Fixes arguments handling (LP: #562965)
+ Fixes seahorse tests (LP: #552618)
+ Fixes ubuntu-menu tests (LP: #551492)
2009-08-04 - Ara Pulido <ara@ubuntu.com>
mago (0.1-0ubuntu1) karmic; urgency=low
[ Ara Pulido ]
* Initial release. (LP: #408951)
[ Iain Lane ]
* Remove recommends on firefox which is unnecessary

See Also

Package Description
mah-jong_1.11-2_amd64.deb Original Mah-Jong game
mahara-apache2_1.4.2-1_all.deb Electronic portfolio, weblog, and resume builder - apache2 configuration
mahara_1.4.2-1_all.deb Electronic portfolio, weblog, and resume builder
mail-expire_0.7_all.deb Utility to extract outdated messages from mbox files
mail-notification-evolution_5.4.dfsg.1-5ubuntu1_amd64.deb evolution support for mail notification
mail-notification_5.4.dfsg.1-5ubuntu1_amd64.deb mail notification in system tray
mailagent_3.1-74-0.1_amd64.deb An automatic mail-processing tool and filter
mailavenger_0.8.2-1_amd64.deb Highly configurable, MTA-independent SMTP filter server
mailcheck_1.91.2-2_amd64.deb Check multiple mailboxes/maildirs for mail
mailcrypt_3.5.9-4_all.deb An Emacs interface to GPG and PGP
maildir-bulletin_0.69_amd64.deb Deliver bulletins directly to the users' Maildir
maildir-filter_1.20-2ubuntu1_amd64.deb Simple program to filter messages into Maildir folders from dot-qmail
maildir-utils-extra_0.9.8.2-1_amd64.deb Extra utilities for maildir-utils
maildir-utils_0.9.8.2-1_amd64.deb Set of utilities to deal with Maildirs (upstream name mu)
maildirsync_1.2-1_all.deb simple and efficient Maildir synchronisation utility
Advertisement
Advertisement