lv2-extensions-good - LV2 extensions from the "good" set

Distribution: Ubuntu 12.04 LTS (Precise Pangolin)
Repository: Ubuntu Universe amd64
Package name: lv2-extensions-good
Package version: 0~20111202+dfsg0
Package release: 1
Package architecture: all
Package type: deb
Installed size: 210 B
Download size: 29.76 KB
Official Mirror:
LV2 is a simple but extensible successor of LADSPA plugins, intended to address the limitations of LADSPA which many applications have outgrown. The following extensions are provided: * LV2 Data Access ( - Defines a method for plugin UIs to have (possibly marshalled) access to the extension_data function on a plugin instance. * LV2 Dynamic Manifest ( - An LV2-based specification for dynamic data generation. * LV2 Events ( - Defines a generic time-stamped event port type, which can be used to create plugins that read and write real-time events. * LV2 Instance Access ( - Defines a method for plugin UIs to get a direct handle to an LV2 plugin instance (LV2_Handle), if possible. * LV2 MIDI Events ( - Defines an LV2 event type for standard raw MIDI. * LV2 Presets ( - Defines presets (e.g. named sets of control values) for LV2 plugins. * LV2 UI ( - Defines an interface that can be used in LV2 plugins and hosts to create UIs for plugins. * LV2 Units extension ( - Defines a number of units for use in audio processing. * LV2 URID ( - Defines a simple mechanism for plugins to map URIs to and from integers, usually for performance reasons. This extension is intended as an improved and simplified replacement for the uri-map extension, since the map context parameter has been found problematic. New implementations are strongly encouraged to use this extension for URI mapping. This package provides the LV2 extensions from the "good" set, a set of extensions which have been discussed and reviewed by the LV2 community and implemented in released software.




  • lv2-extension


    Source package: lv2-extensions-good

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install lv2-extensions-good deb package:
      # sudo apt-get install lv2-extensions-good


    • /usr/include/lv2/
    • /usr/include/lv2/
    • /usr/include/lv2/
    • /usr/include/lv2/
    • /usr/include/lv2/
    • /usr/include/lv2/
    • /usr/include/lv2/
    • /usr/include/lv2/
    • /usr/include/lv2/
    • /usr/include/lv2/
    • /usr/lib/lv2/data-access.lv2/data-access.h
    • /usr/lib/lv2/data-access.lv2/data-access.ttl
    • /usr/lib/lv2/data-access.lv2/manifest.ttl
    • /usr/lib/lv2/dynmanifest.lv2/dynmanifest.h
    • /usr/lib/lv2/dynmanifest.lv2/dynmanifest.ttl
    • /usr/lib/lv2/dynmanifest.lv2/lv2-dynmanifest.doap.ttl
    • /usr/lib/lv2/dynmanifest.lv2/manifest.ttl
    • /usr/lib/lv2/event.lv2/event-helpers.h
    • /usr/lib/lv2/event.lv2/event.h
    • /usr/lib/lv2/event.lv2/event.ttl
    • /usr/lib/lv2/event.lv2/manifest.ttl
    • /usr/lib/lv2/instance-access.lv2/instance-access.h
    • /usr/lib/lv2/instance-access.lv2/instance-access.ttl
    • /usr/lib/lv2/instance-access.lv2/manifest.ttl
    • /usr/lib/lv2/midi.lv2/manifest.ttl
    • /usr/lib/lv2/midi.lv2/midi.ttl
    • /usr/lib/lv2/presets.lv2/manifest.ttl
    • /usr/lib/lv2/presets.lv2/presets.ttl
    • /usr/lib/lv2/ui.lv2/lv2-ui.doap.ttl
    • /usr/lib/lv2/ui.lv2/manifest.ttl
    • /usr/lib/lv2/ui.lv2/ui.h
    • /usr/lib/lv2/ui.lv2/ui.ttl
    • /usr/lib/lv2/units.lv2/lv2-units.doap.ttl
    • /usr/lib/lv2/units.lv2/manifest.ttl
    • /usr/lib/lv2/units.lv2/units.ttl
    • /usr/lib/lv2/uri-map.lv2/manifest.ttl
    • /usr/lib/lv2/uri-map.lv2/uri-map.h
    • /usr/lib/lv2/uri-map.lv2/uri-map.ttl
    • /usr/lib/lv2/urid.lv2/manifest.ttl
    • /usr/lib/lv2/urid.lv2/urid.h
    • /usr/lib/lv2/urid.lv2/urid.ttl
    • /usr/lib/pkgconfig/
    • /usr/lib/pkgconfig/
    • /usr/lib/pkgconfig/
    • /usr/lib/pkgconfig/
    • /usr/lib/pkgconfig/
    • /usr/lib/pkgconfig/
    • /usr/lib/pkgconfig/
    • /usr/lib/pkgconfig/
    • /usr/lib/pkgconfig/
    • /usr/lib/pkgconfig/
    • /usr/share/doc/lv2-extensions-good/changelog.Debian.gz
    • /usr/share/doc/lv2-extensions-good/copyright